Every now and then SmartGit complains about my version of git on Mac OS X. It says I don’t have a recent enough version of the git executable. I have SmartGit configured to use the git executable found in /usr/bin/git on my Mac. Now, I know that the version meets the minimum requirements, so what’s the problem.

This often occurs after an update to Xcode and the problem is related to Apple wanting me to agree to the licensing terms (yet again). I have to manually execute git in order to view and agree to the new license terms.

To do so and fix the problem run:

sudo /usr/bin/git --version

…then follow the prompts to agree to the new Xcode license terms. Problem solved.

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published.